ヘルプ

SofTalk

【目次】
・ 機能説明
・ 通常画面
・ 環境設定画面
  ┗ 辞書編集方法・発音設定方法
・ 多重起動を行う場合
・ 引数指定
・ アンインインストール
・ 注意事項
・ そ の 他
・ 製作著作

【機能説明】
漢字・英字等を含む文章を音声合成で読み上げます。

引数に文章／オプションを指定すれば画面表示せずに読み上げを開始するので、他のアプリケーションから呼び出して使用することもできます。

【通常画面】

入力欄 | 読み上げたい文章を入力します。 再生ボタン押下後に文章の任意の行をダブルクリックすると、読み上げ位置をその行に移動します。
プリセット | 環境設定画面（後述）で登録した設定を反映します。
声 | 声を選択します。
音量 | 読み上げの音量を変更します。
速度 | 読み上げの速度を変更します。（標準100）
音程 | 音程を変更します。（標準100） ■Miko Voiceの場合、音程は読み上げ速度にも影響します。 ■唄詠の場合、音程は反映されません。
再生ボタン | 読み上げを開始します。
一時停止ボタン | 読み上げを一時停止・再開します。
中止ボタン | 読み上げを終了します。
前行ボタン | 前の行に移動します。
次行ボタン | 次の行に移動します。
消去ボタン | 文章を消去します。
録音ボタン | 読み上げた内容をWAVEファイルとして保存します。 ■設定によっては、録音ボタン押下後に再生ボタンを押す必要があります。 ■録音中に音程を変えた場合、録音終了時の音程がWAVEファイルに反映されます。
ステータスバー | メッセージや、読み上げ状況を表示します。 ■文字数：読み上げた文字数／全体の文字数（概算） ■時間：経過した時間／読み上げ完了予定（概算）

■ショートカットキーからも各ボタンが操作できます。（キー設定にて変更可能）
■「ファイル」－「テキストを開く」を選んでテキストファイルを指定するとテキスト内容が表示されます。
■「ファイル」－「テキストを保存」を選ぶとテキスト内容を保存できます。
■「声」にて文章を読み上げる声が選択可能です。
■「オプション」－「リピート再生」をチェックすると、繰り返し再生を行います。
■テキストファイルをドラッグ＆ドロップすることでもテキスト内容の表示が可能です。

【環境設定画面】

オプション－環境設定を選択すると様々な設定を変更することができます。
よみがな | 略語や顔文字などの読み仮名の設定ができます。 ■選択した読み仮名の優先順序を▲▼ボタンで入れ替えます。 （上にある情報が優先されます。 ） ■優先順位を指定すると、一覧の指定した行に読み仮名が登録されます。 ■一覧を右クリックして「一覧をソートする」を選ぶと単語順にソートできます。 ■「全/半角を区別」にチェックすると、全/半角・大/小文字を区別して単語を読み仮名に置き換えます。 ■読み仮名には「,」を含む句読点を使用できます。
 | よみがな以外にも、辞書を編集することで読み上げ精度や発音を向上することができます。 辞書についての詳細はこちらをご覧下さい。
読み上げ | 【長文に自動で句読点をつける】 助詞のあとに自動で句読点をつけます。
 | 【ENTERで再生＆クリア】 ENTERで文章の再生とクリアを行います。
 | 【読み上げ内容をタイトルに表示】 現在読み上げている内容をタイトルバーに表示します。
 | 【読み上げ箇所を選択表示】 現在読み上げている箇所を選択表示します。
 | 【クリップボードを読み上げる】 コピーした文章を読み上げます。クリップボードの内容が消去されますのでご注意下さい。
 | 【選択箇所を読み上げ】 選択している箇所のみ読み上げます。
 | ■長文制限：文章が指定した文字数を超えると読み上げを中断します。 ■連続ｗ→ﾜﾗﾜﾗ：ｗが続く場合にわらわらと読み上げます。 ■句点間隔：句点・疑問符の読み上げ間隔を調整します。（Miko Voice） ■読点間隔：読点の読み上げ間隔を調整します。（Miko Voice） ■その他間隔：コンマの読み上げ間隔を調整します。（SAPI／Speech Platform）
置換 | 検索する文字を、置換後の文字に置き換えるための情報を設定します。 ■読み飛ばしの設定としても使えます。 ■選択した置換情報の優先順序を▲▼ボタンで入れ替えます。 （上にある情報が優先されます。 ） ■優先順位を指定すると、一覧の指定した行に置換情報が登録されます。 ■一覧を右クリックして「一覧をソートする」を選ぶと単語順にソートできます。 ■「全/半角を区別」にチェックすると、全/半角・大/小文字を区別して置換後の文字に置き換えます。
正規表現 | 正規表現による変換を設定します。 ■読み上げ対象の限定や読み飛ばしの設定としても使えます。 ■選択した正規表現の優先順序を▲▼ボタンで入れ替えます。 （上にある情報が優先されます。 ） ■一覧を右クリックして「一覧をソートする」を選ぶと単語順にソートできます。 ■正規表現の表記方法については 各種サイト を参考にするとよいでしょう。
音声記号 | 検索する文字を、置換後の音声記号に置き換えるための情報を設定します。 ■選択した置換情報の優先順序を▲▼ボタンで入れ替えます。 （上にある情報が優先されます。 ） ■優先順位を指定すると、一覧の指定した行に置換情報が登録されます。 ■一覧を右クリックして「一覧をソートする」を選ぶと単語順にソートできます。 ■「全/半角を区別」にチェックすると、全/半角・大/小文字を区別して置換後の文字に置き換えます。
読み飛ばし | 指定したワードを含む行を読み飛ばします。
表示 | 書式や前面表示を設定します。 「ひらがな表示」にチェックすると文章を読み上げた後、ひらながで表示します。
声質 | 声の種類や再生デバイス、音質を変更できます。 Microsoft SAPI 5.1以上やMicrosoft Speech Platformがインストールされていれば、それらの声を選択することも可能です。 どの声がMiko Voice/SAPI/Speech Platformに該当するかは、一覧の右端に記載しています。 声のメーカー名も一覧の右端で確認できます。
 | 【Miko Voice】 ■平仮名をチェックすると、辞書に従い文章を平仮名に置き換えてから読み上げます。（推奨） ■抑揚をチェックすると、抑揚をつけて読み上げます。 ■両方のチェックを外すと文章をそのまま読み上げます。音声記号列を読み上げる際に使用します。 [実行例] きょ'うわ、お'んがくを/<NUMK VAL=300 COUNTER=きょく>きいた。 ■空耳・唄詠はチェックできません。 ■Phontをお持ちの場合、dll\aqt2\phontにコピーすると、次回起動時に声の種類が追加されます。
 | 【SAPI／Speech Platform】 ■平仮名をチェックすると、辞書に従い文章を平仮名に置き換えてから読み上げます。 ■空耳をチェックすると、辞書に従い日本語に聞こえる英語に置き換えてから読み上げます。 （英語圏の話者用、例：Microsoft Samなど） ■唄詠をチェックすると、音声記号列に置き換えてから文章を読み上げます。 （唄詠エンジン用、平仮名・抑揚が自動でチェックされます） ■XML TTSが使用できます。詳細はMicrosoftの「XML TTS Tutorial」をご覧下さい。 ※平仮名・抑揚・空耳・唄詠のチェックを外してご利用下さい。 ※Open JTalkではご利用になれません。 ※タグの間に改行・句読点を用いることはできません。 [実行例] 2000ミリ秒<silence msec="2000"/>沈黙します。 ■「。」「、」による間や、使用できるXML TTSはエンジンに依存します。 ■空耳は日本語の話者に対してはチェックできません。 ■唄詠・抑揚は唄詠エンジン以外に対してはチェックできません。
プリセット | 声・音量・速度・音程・高さ・アクセント・音程2の設定を別名を付けて保存できます。 プリセットは、通常画面で声の設定を切り替える場合に使用します。
条件 | 登録した単語を含む文章を、指定した声／プリセットで読み上げます。 文章によって声／プリセットを変えて、会話を行わせたい場合などに使用します。 ■全/半角を区別：登録された単語の全/半角・大/小文字を区別します。 ■▲▼：選択した声の優先順序を入れ替えます。（上にある情報が優先されます。 ）
録音 | 【録音時は読み上げを省略する】 録音時の読み上げを省略します。
 | 【録音時に自動でファイル名をつける（引数指定を除く）】 録音時のファイル名に数字を自動で設定します。
 | 【録音時にテキストを自動保存する】 録音時に音声と同じファイル名（拡張子はtxt）でテキストを保存します。
 | 【録音開始時に自動再生する】 文章を入力した状態で録音ボタンを押すと自動で再生を開始します。 （自動再生をオフにした状態では、再生ボタンを押すまで録音されません。）
キー設定 | 各ボタンを操作するためのショートカットキーを設定します。 テキスト欄にカーソルを合わせて設定したいキーを押して下さい。 ■環境により、一部のキーが使用できない場合があります。 ■キー設定の変更は再起動後に有効になります。
その他 | 【引数をファイル名／オプションとして処理する】 引数を文章ではなく、ファイル名／オプションとして処理します。詳細は 引数指定 をご覧下さい。
 | 【設定ファイルをバックアップする】 設定ファイルを５世代分バックアップします。

【多重起動を行う場合】
softalkw.exeをご利用下さい。

【引数指定】
引数を指定する場合は、Windowsスタートメニューの「ファイル名を指定して実行」・ショートカットのプロパティ・コマンドプロンプト等を使用します。
簡易的に文章を読ませる場合は「引数をファイル名／オプションとして処理する」のチェックを外し、次のように指定します。
"C:\SofTalk.exe" 読み上げサンプル
「引数をファイル名／オプションとして処理する」にチェックすると、引数から以下のような操作が行えます。

■次のように指定すると、テキストファイルを読み上げます。
"C:\SofTalk.exe" テキストファイルのパス

■オプションには設定オプションと実行オプションがあります。

■設定オプションの種類は次の通りです。

種類 | 値 | 効果 | 詳細 | 備考
/NM: | 文字列 | 声指定 | 声を名前で指定 | 例）"C:\SofTalk.exe" /NM:女性01
/PR: | 文字列 | プリセット指定 | プリセットを名前で指定 | 例）"C:\SofTalk.exe" /PR:初期設定
/PS: | True False | 読み上げ省略 | True:録音時の読み上げを省略 False:省略しない | 例）"C:\SofTalk.exe" /PS:True /R:"C:\a.wav"
/M: | 0～? | 声指定 | 声を番号で指定 | 0から始まる通し番号
/N: | 0～? | プリセット指定 | プリセットを番号で指定 |
/O: | 0～300 | 音程 | 声の音程 |
/P: | 読み | 読み追加 | 読み（平仮名）・単語・全/半角を区別 （True/False）をコンマ区切りで指定 | 例）"C:\SofTalk.exe" /P:てすと,Tｅst,True 登録済みの単語の場合は以前の単語を更新
/Q: | 0～5 | 読み上げ方 | 0:平仮名変換無・抑揚無 1:平仮名変換無・抑揚有 2:平仮名変換有・抑揚無 3:平仮名変換有・抑揚有 4:平仮名変換有・抑揚無・空耳有 5:平仮名変換有・抑揚有・唄詠有 | 選択中のライブラリに対して設定 ※１
/R: | パス | 録音 | 読み上げた文章の録音 |
/S: | 1～300 | 速度 | 読み上げの速度 |
/T: | 8～15 | ライブラリ指定 | ライブラリ（エンジン）の指定 8:SAPI 9:Speech Platform 12:Miko Voice 13:Miko Voice（和音） 14:Miko Voice（ハモリランダム） 15:SAPI（OneCore） | ※２
/U: | 0～? | 声指定 | ライブラリ（エンジン）から声を指定 | 選択中のライブラリに対して設定 ※１ ※３
/V: | 0～100 | 音量 | 声の音量 |
/W: | 文章 | 文章 | 読み上げたい文章 | このオプション以降の文字は全て文章とみなす ※４
/X: | 0～1 | 画面表示 | 0:表示 1:非表示 | 起動時のみ有効 ※５
/Z: | パス | XML出力 | 指定可能な声をXML形式で出力 (Shift-JIS・UTF-16) | ※６
/ZZ:

※１：目的とするライブラリを選択後に設定して下さい。
      女性１の声で読み上げる場合は次のような間違いにご注意下さい。
      ×"C:\SofTalk.exe" /Q:0 /U:0 /T:0 W:ハロー
      ○"C:\SofTalk.exe" /T:0 /Q:0 /U:0 W:ハロー
※３：指定できる声の種類はPCの環境によって異なります。
      （SAPI／Speech Platformのいずれもユーザー自身で声を追加インストールできるため。）
      /Z:でXMLを出力し、指定できる値をご確認下さい。
※４：指定した文章を録音する際は次のような間違いにご注意下さい。
      ×"C:\SofTalk.exe" /W:ハロー /R:C:\test.wav
      ○"C:\SofTalk.exe" /R:C:\test.wav /W:ハロー
※５：非表示にて起動した場合、後述の実行オプションを用いて終了させる必要があります。
※６：libraryタグのoptの内容がライブラリ（エンジン）の、voiceタグのoptの内容が声の選択時のオプションに使用できます。
[実行例]
"C:\SofTalk.exe" C:\test.txt
C:\test.txtを読み上げます。

"C:\SofTalk.exe" C:\test.txt /W:ハロー
「ハロー」と読み上げた後、test.txtを読み上げます。

"C:\SofTalk.exe" /T:2 /S:50 /V:60 /R:c:\test.wav /W:ハロー
「ハロー」と男性１の声でゆっくり・大きな声で読み上げ、読み上げた内容をc:\test.wavに保存します。

"C:\SofTalk.exe" /W:ハロー /T:2 /S:50 /V:60 /R:c:\test.wav
「ハロー /T:2 /S:50 /V:60 /R:c:\test.wav」と読み上げます。
■実行オプションの種類は次の通りです。
［順次実行オプション］
/play　再生
/stop　中止
/pause　一時停止
/resume　一時停止解除
/next　次行
/previous　前行
/repeat　リピート
/no-repeat　リピート解除
/clear　クリア
/close　終了
/close2　終了（変更を保存しない）

［即時実行オプション］
/play_now　再生
/stop_now　中止
/pause_now　一時停止
/resume_now　一時停止解除
/next_now　次行
/previous_now　前行
/repeat_now　リピート
/no-repeat_now　リピート解除
/clear_now　クリア
/close_now　終了
/close2_now　終了（変更を保存しない）
■実行オプションはアプリケーションなどからSofTalkを呼び出す場合に使用します。

■実行オプションはファイル名や他のオプションと同時に指定することはできません。

■/close2、/close2_nowは変更された設定を保存せずにSofTalkを終了します。
   設定オプションにて変更した声・読み上げ速度などを破棄する場合に使用します。
   （環境設定にて変更した内容も保存されません。）

■設定オプション・順次実行オプションは引数を受け取った順番で、即時実行オプションは最優先で実行されます。
[実行例]
"C:\SofTalk.exe" C:\test.txt /T:2
"C:\SofTalk.exe" /close
C:\test.txtの読み上げが終わるとSofTalkを終了します。
男性１の声が次回起動時の初期値になります。

"C:\SofTalk.exe" C:\test.txt /T:2
"C:\SofTalk.exe" /close2_now
C:\test.txtの読み上げが終わるのを待たずにSofTalkを終了します。
男性１の声は次回起動時に影響しません。

"C:\SofTalk.exe" C:\test.txt /T:2 /S:50 /V:60
"C:\SofTalk.exe" /pause
"C:\SofTalk.exe" C:\test2.txt
"C:\SofTalk.exe" /resume_now
C:\test.txtの読み上げを一時停止後、読み上げを再開します。
読み上げが終わったらC:\test2.txtを読み上げます。

"C:\SofTalk.exe" C:\test.txt /T:2 /S:50 /V:60
"C:\SofTalk.exe" /pause
"C:\SofTalk.exe" C:\test2.txt
"C:\SofTalk.exe" /resume
C:\test.txtの読み上げを一時停止します。
SofTalkの一時停止ボタンをクリックして解除するまで、読み上げは再開されません。

"C:\SofTalk.exe" C:\test1.txt
"C:\SofTalk.exe" C:\test2.txt
"C:\SofTalk.exe" /clear
"C:\SofTalk.exe" C:\test3.txt
"C:\SofTalk.exe" /pause
/clear以降に待機中の実行オプションがあれば、無視します。
この場合、C:\test3.txtの読み上げと一時停止は実行されません。

"C:\SofTalk.exe" C:\test1.txt
"C:\SofTalk.exe" C:\test2.txt
"C:\SofTalk.exe" C:\test3.txt
"C:\SofTalk.exe" C:\test4.txt
"C:\SofTalk.exe" /clear_now
待機中の実行オプションがあれば、無視します。
C:\test1.txtを読み上げ中の場合、C:\test2.txt～C:\test4.txtの読み上げは実行されません。
※実行例は全てC:\にSofTalk.exeとtest.txtがある場合

【アンインストール】
フォルダごと削除して下さい。

【注意事項】
本ソフトをご利用になるにはMicrosoft .NET Frameworkが必要です。

Waveファイルの変換処理は下記ライブラリを参考にしています。
Copyright (c) 2019 Takeshi Okamoto
MIT License
https://github.com/TakeshiOkamoto/WAVE.js/
https://github.com/TakeshiOkamoto/WAVE.js/blob/master/LICENSE

【そ の 他】
本ソフトはフリーウェアです。
本ソフトのご利用に際し如何なる損失や損害が発生しても、一切の責任を負いかねます。

ご不明な点がございましたら公式サイトのFAQまたはBBSをご利用下さい。
まだ開発中なので、機能不足はお目こぼしを。

【製作著作】
SofTalk Ver 1.93.63
2006-2022

cncc
 https://w.atwiki.jp/softalk/


ヘルプ

【目次】
辞書ファイルの説明
単語ファイルの説明
助数詞ファイルの説明
英語ファイルの説明
記号ファイルの説明
発音について
日英ファイルの説明
注意事項
戻る

【dic.stkについて】
dllフォルダのdic.stkをメモ帳等で編集すれば漢字の読み上げ精度を向上することができます。

dic.stkはフリーライセンスの漢字辞書を元に作成しました。
SofTalkでは文中の単語に合致するものをこのファイルから検索し、平仮名に置き換えています。

主に漢字の変換を目的とし、単語＋平仮名２文字までが扱えます。

【dic.stkの書式】
単語+スペース+読み1,読み2,･･･,読みn+スペース+読み1分類,読み2分類,･･･,読みn分類+スペース+ 発音（後述）

【分類の内訳】
読み仮名の分類は数字で表され、内容は以下の通りになっています。
（名目上、品詞が用いられていますが、実際の品詞の判別方法とは異なります。）
番号 | 意味 | 備考
0 | 記号_外国 | 未使用
1 | カ行五段 | 後に「か,き,く,け,こ,い,っ」が付く単語・漢字 例）行「か」ない・行「き」ます・行「く」・行「け」ば・行「こ」う・行「っ」た
2 | ガ行五段 | 後に「が,ぎ,ぐ,げ,ご,い」が付く単語・漢字
3 | サ行_する | 後に「さ,し,す,せ,そ」が付く単語・漢字
4 | ザ行_ずる | 後に「ざ,じ,ず,ぜ,ぞ」が付く単語・漢字
5 | サ行_する_名詞 | 後に「さ,し,す,せ,そ」が付く単語・漢字
6 | サ行五段 | 後に「さ,し,す,せ,そ」が付く単語・漢字
7 | タ行五段 | 後に「た,ち,つ,て,と,っ」が付く単語・漢字
8 | ナ行五段 | 後に「な,に,ぬ,ね,の,ん」が付く単語・漢字
9 | バ行五段 | 後に「ば,び,ぶ,べ,ぼ,ん」が付く単語・漢字
10 | マ行五段 | 後に「ま,み,む,め,も,ん」が付く単語・漢字
11 | ラ行五段 | 後に「ら,り,る,れ,ろ,っ」が付く単語・漢字
12 | ワ行五段 | 後に「わ,い,う,え,お,っ」が付く単語・漢字
13 | 一段 | 後に「た,て,な,に,ぬ,ね,よ,ら,る,れ,ろ,ず,ち」が付く単語・漢字
14 | 一段_名詞 | 後に「た,て,な,に,ぬ,ね,よ,ら,る,れ,ろ,ず,ち」が付く単語・漢字
15 | 一動幹 |
16 | 形容詞 | 後に「か,く,き,け,い,う,し,が,さ,そ,め」が付く単語・漢字
17 | 形容動詞 | 後に「た,だ,で,と,な,る,に,が」が付く単語・漢字
18 | 形容動詞_名詞 | 同上
19 | 形容動詞_たる | 同上
20 | 形容動詞化接尾語 |
21 | 固有名詞 |
22 | 人名 |
23 | 数詞 | 数字の後につく単語・漢字
24 | 接続詞_感動詞 |
25 | 接頭語_名詞 | カタカナの前に付く単語・漢字
26 | 単漢字 |
27 | 地名 |
28 | 副詞 |
29 | 名詞 |
30 | 連体詞 |
31 | 人名_地名 |
32 | 接尾語_名詞 | 数字・カタカナ・英字等の後に付く一文字の漢字
33 | 接尾語_する |
34 | 接尾辞A | １．形容詞・形容動詞・形容動詞_名詞・形容動詞_たる・連体詞の後に付く漢字 ２．前に「た,だ,う,く,す,る,の」が付く漢字
35 | 接尾辞B | １．サ行_する・ザ行_ずる・ サ行_する_名詞の後に付く漢字 ２．前に「り,み,に,い,き,し,え,れ,め」が付く漢字
36 | 接尾辞C | 地名・名詞・人名_地名の後に付く漢字
99 | その他 | 分類不可、もしくは平仮名

【比較方法について】
単語は以下の順番で辞書と比較し、平仮名に置き換えています。
いずれも合致しない場合、単語の右端を１文字除いて１～４を繰り返します。
優先順位 | 種類 | 変換前の例 | 変換後の例
1 | 単語＋平仮名２文字 | 朗＋らか | ほがらか
2 | 単語＋平仮名１文字＋番号 | 赤＋ら＋ま～も | あからむ
3 | 単語＋番号 | 一郎 | いちろう
4 | 単漢字 | 茜 | あかね

【読み仮名の優先順位】
同じ単語で読み仮名が複数存在する場合、以下の優先順位で読み仮名が採用されます。
優先順位 | 種類 | 備考
1 | 環境設定－正規表現の設定 |
2 | 環境設定－読み上げの単語 | 強制置換
3 | 接尾語_名詞 | 【分類の内訳】の備考の条件に合致する場合
4 | 数詞 | 【分類の内訳】の備考の条件に合致する場合
5 | 接頭語_名詞 | 【分類の内訳】の備考の条件に合致する場合
6 | 接尾辞A | 【分類の内訳】の備考の条件１に合致する場合
7 | 接尾辞B | 【分類の内訳】の備考の条件に合致する場合
8 | 接尾辞A | 【分類の内訳】の備考の条件２に合致する場合
9 | 接尾辞C | 【分類の内訳】の備考の条件に合致する場合
10 | カ行五段ガ行五段・サ行_する・ サ行_する_名詞・サ行五段・ ザ行_ずる・タ行五段・ナ行五段・ バ行五段・マ行五段・ラ行五段・ ワ行五段・一段・一段_名詞・ 形容詞・形容動詞・形容動詞_名詞・ 形容動詞_たる | 【分類の内訳】の備考の条件に合致する場合
11 | 地名・人名_地名 | dic.stkの左側にあるものを優先
12 | 接尾語_する | 単語の後に付く漢字一文字
13 | 接尾語_名詞 | 単語の後に付く漢字一文字
14 | サ行_する_名詞・形容動詞化接尾語・ 形容動詞_名詞・一動幹・固有名詞・ 数詞・接続詞_感動詞・単漢字・ 副詞・名詞・連体詞 | dic.stkの左側にあるものを優先

【既知の問題点】
〇ピアノを弾く（ひく）・鍵盤を弾く（はじく）等の読み分けはできません。（「ひく・はじく」はいずれもカ行五段）
〇単語に記号を登録するとエラーとなる場合があります。

【join.stkについて】
dllフォルダのjoin.stkを編集すれば種類の異なる文字を一つの単語として取り扱うことができます。
これはdic.stkやeng.stkによる平仮名への置き換えに影響します。

【join.stkの書式】
１．種類1+スペース+種類2+スペース+種類3
もしくは
２．種類1+スペース+種類2+スペース

【種類の内訳】
文字の種類は数字で表され、内容は以下の通りになっています。
番号 | 意味 | 備考
0 | 記号 | 句読点・共通・外国を除く記号
1 | 外国 | 英字を除く外国の文字
2 | 数字 | アラビア数字
3 | 英字 | アルファベット
4 | 平仮名 |
5 | 片仮名 |
6 | 共通 | 長音符号
7 | 句読点 |
8 | 漢字 |

【判別方法について】
以下の条件を満たす場合、それを一つの単語として取り扱います。
・文中から任意の３文字を抜粋し、書式１に合致した場合（種類2を種類3の文字とみなす）
・文中から任意の２文字を抜粋し、書式２に合致した場合（種類1を種類2の文字とみなす）
例 | 意味 | 文中の文字 | 結果
8 4 8 | 漢字＋平仮名＋漢字 | 赤ら顔 及び腰 | 「ら・び」を漢字とみなす

【判別の優先順位】
先に登録された内容が優先して採用されます。

【文字の特定】
種類の後に続けてコンマ区切の文字列を指定することで、特定の文字を含む場合のみ判別の対象とすることができます。
例 | 意味 | 文中の文字 | 結果
8 4,ら,っ,ん,い,け,し,に,り 8 | 漢字＋ら,っ,ん,い,け,し,に,り＋漢字 | 赤ら顔 | 「ら」を漢字とみなす

【num.stkについて】
dllフォルダのnum.stkを編集すれば助数詞の読み上げ精度を向上することができます。
num.stkは「１杯・３杯」のように前につく数字で助数詞の読みが変わる場合や、「いちはい→いっぱい」と数字の読みが変わる場合に効果があります。

【num.stkの書式】
単語＋スペース＋読み仮名＋スペース＋濁点・半濁点

【濁点・半濁点の内訳】
濁点・半濁点の種類は数字で表され、内容は以下の通りになっています。
番号 | 意味 | 備考
0 | 濁音・半濁音が付かない |
1 | 一桁目が3の場合、濁音が 一桁目が6･8の場合半濁音が付く |
2 | 一桁目が1･3･6･8の場合、半濁音が付く | いっぷん・にふん・さんぷん・よんふん・ごふん・ろっぷん・・・
3 | 一桁目が3の場合、濁音が 一桁目が1･6･8の場合半濁音が付く | いっぽん・にほん・さんぼん・よんほん・ごほん・ろっぽん・・・
4 | 一桁目が3の場合、濁音が付く | いっかい・にかい・さんがい・よんかい・・・

【eng.stkについて】
dllフォルダのeng.stkを編集すれば英語の読み上げ精度を向上することができます。

【eng.stkの書式】
一致レベル+スペース+英単語（小文字）+スペース+読み仮名

【一致レベルの内訳】
一致レベルは数字で表され、内容は以下の通りになっています。
番号 | 意味 | 備考
0 | 完全一致 | 完全に一致する場合（優先順位：最高）
1 | 部分一致1 | 一部が一致する場合（優先順位：高）
2 | 部分一致2 | 一部が一致する場合（優先順位：中）
3 | 部分一致3 | 一部が一致する場合（優先順位：低）
4 | その他一致 | アルファベット一文字が一致する場合（優先順位：最低）

【mrk.stkについて】
dllフォルダのmrk.stkを編集すれば記号の読み方を変更することができます。
mrk.stkは主にdic.stkで取り扱いできない記号を取り扱い可能な文字に置き換える目的で使用します。

【mrk.stkの書式】
記号+スペース+単語

【発音について】
漢字についてはdic.stkにてAquesTalkのアクセント記号を使用することができます。
また平仮名・片仮名などについてはacc.stkにて設定が可能です。

アクセント記号の詳細はAquesTalkの公式サイトにてライブラリをダウンロードしていただき、同梱されている音声記号列仕様書をご覧下さい。

【dic.stkの発音の書式】
前途の書式 +スペース+読み1のアクセント位置,読み2のアクセント位置,･･･,読みnのアクセント位置

【dic.stkのアクセント指定方法について】
アクセント位置は数字で指定します。
数字の１なら１文字目の後にアクセント記号を付けることを意味します。（「ゃゅょっ」なども一文字に数えます）
１つの読みに対してアクセント記号を複数指定する場合、「-」（ハイフン）で区切ります。
また、「'」（ダッシュ）以外のアクセント記号を指定する場合、数字の後に続けてアクセント記号を記述します。
例 | 音声記号 | 発音イメージ
亜種 あしゅ 29 1 | あ'しゅ | ￣＼
阿鼻叫喚 あびきょうかん 29 1-2; | あ'び;きょうかん | ￣V￣＼＿＿
阿鼻叫喚 あびきょうかん 29 1'-2;

【acc.stkの発音の書式】
文字の種類 +スペース+ 読み仮名の分類 +スペース+置換前の文字列+スペース+置換後の文字列＋一致場所

【一致場所の内訳】
一致場所は数字で表され、内容は以下の通りになっています。
番号 | 意味 | 備考
0 | 部分一致 | 文字列の一部に一致する場合
1 | 前方一致 | 文字列の前方に一致する場合
2 | 後方一致 | 文字列の後方に一致する場合
3 | 完全一致 | 文字列に完全一致する場合
前方一致・後方一致・完全一致は最初に合致したもののみ採用されます。

尚、ここでの文字列とは平仮名・片仮名など種類毎に分けられた文字を指します。
例えば文字の種類に「平仮名」、置換前の文字列に「だった」、一致場所に「前方一致」を指定した場合、
「昨日は遅寝だったが今日も元気だった」
のような文章では
「昨日は遅寝 だった が今日も元気 だった」
の２箇所が置換対象となります。

【acc.stkのアクセント指定方法について】
置換前の文字列に文章の一部を、置換後の文字列にアクセント記号込みの文字列を指定します。
尚、置換前・変換後の文字列については助詞の「は・へ」は「わ・え」に、また助詞か否かに関わらず「づ・ヅ・ぢ・ヂ」は「ず・ズ・じ・ジ」にすることに注意して下さい。
例 | 音声記号 | 発音イメージ
4 5 そろそろ そ'ろそろ 0 | そ'ろそろ | ￣＼＿＿
4 99 これわすごい これわ/すご'い 3 | これわ/すご'い | ―――＿／＼

【アクセントの自動変換について】
「漢字の単語」もしくは「片仮名かつ完全一致かつサ行_する_名詞」の後に「漢字の単語かつサ行_する_名詞・名詞・連体詞・接尾語_名詞のいずれか」が続く場合、設定を無視して直前の文字列の語尾を上げて発音します。
例 | 音声記号 | 発音イメージ
校外 | こ'うがい | ￣＼＿＿
学習 | がくしゅう | ――――
校外学習 | こうがい'がくしゅう | ＿＿＿／＼＿＿＿
バチスタ | ばち'すた | ＿／＼＿
手術 | しゅじゅつ | ―――
バチスタ手術 | ばちすた'しゅじゅつ | ＿＿＿／＼＿＿

【j2e.stkについて】
dllフォルダのj2e.stkを編集すれば日本語を英語読みする際の読み方を変更することができます。
１行あたり最大５文字までの平仮名とカタカナを登録でき、上位にあるものほど優先的に変換されます。

【注意事項】
〇各ファイルに誤った書式を指定するとエラーとなります。
〇\・$・￡・￠は内部の処理にて円・ドル・ポンド・セントに置き換えられます。
   （環境設定－読み上げの設定にて既に読み仮名に置換されている場合を除く）